aburrell/aacgmv2

View on GitHub
.travis.yml

Summary

Maintainability
Test Coverage
language: python
python:
  - "3.6"
  - "3.7"
  - "3.8"
  - "3.9"
env:
  global:
    - LD_PRELOAD=/lib/x86_64-linux-gnu/libSegFault.so
before_install:
  - python --version
  - uname -a
  - lsb_release -a
install:
  - pip install numpy tox-travis coveralls
  - python setup.py install
script:
  - |
    if [ $TRAVIS_PYTHON_VERSION == "3.7" ]; then
        tox -e check,docs
    fi
  - tox -e $TRAVIS_PYTHON_VERSION
after_success:
  - coveralls --rcfile=setup.cfg
notifications:
  email:
    on_success: never
    on_failure: always