coi-gov-pl/puppet-jboss

View on GitHub
metadata.json

Summary

Maintainability
Test Coverage
{
  "name":         "coi-jboss",
  "version":      "1.3.0-pre",
  "author":       "Center of Information Technology COI.gov.pl",
  "summary":      "Installs JBoss EAP and WildFly application servers and manage their resources and applications in either a domain or a stand-alone mode",
  "license":      "Apache-2.0",
  "source":       "git://github.com/coi-gov-pl/puppet-jboss.git",
  "project_page": "https://github.com/coi-gov-pl/puppet-jboss",
  "issues_url":   "https://github.com/coi-gov-pl/puppet-jboss/issues",
  "dependencies": [
    { "name": "puppetlabs/java",   "version_requirement": ">= 1.0.1 <2.0.0" },
    { "name": "puppetlabs/stdlib", "version_requirement": ">= 3.2.0 <5.0.0" },
    { "name": "puppetlabs/concat", "version_requirement": ">= 1.0.0 <2.0.0" }
  ],
  "operatingsystem_support": [
    { "operatingsystem": "RedHat",      "operatingsystemrelease": [ "6" ] },
    { "operatingsystem": "CentOS",      "operatingsystemrelease": [ "6" ] },
    { "operatingsystem": "OracleLinux", "operatingsystemrelease": [ "6" ] },
    { "operatingsystem": "Scientific",  "operatingsystemrelease": [ "6" ] },
    { "operatingsystem": "Debian",      "operatingsystemrelease": [ "8" ] },
    { "operatingsystem": "Ubuntu",      "operatingsystemrelease": [ "14.04" ] }
  ],
  "requirements": [
    { "name": "puppet", "version_requirement": ">=2.7.0 <4.0.0" }
  ]
}