gotois/ProstoDiary_bot

View on GitHub
Update dependency ava to v5 #15353
renovate[bot] authored a3fade67
errored00:00:10
An engine encountered an error
E10 Error

We had trouble running the eslint engine.

The engine's output shown below may indicate the cause of the error.

If not, please contact us so we can investigate further.

1
git clone
2
codeclimate validate-config
View output
codeclimate validate-config
No errors or warnings found in .codeclimate.yml.
3
codeclimate prepare
View output
codeclimate prepare
4
builder pull-engines
View output
determining required images
5
structure
View output
12
Parser process id: 12
codeclimate-parser socket not present
waiting 1s...
6
duplication
View output
12
Parser process id: 12
codeclimate-parser socket not present
waiting 1s...
7
eslint
eslint engine documentation
View output
Module not supported: eslint-plugin-ava
Module not supported: eslint-plugin-unicorn
/usr/src/app/lib/validate_config.js:18
        throw e;
        ^

Error: Cannot find module 'eslint-plugin-unicorn'
Require stack:
- /usr/local/node_modules/eslint/lib/config/config-file.js
- /usr/src/app/lib/eslint-patch.js
- /usr/src/app/lib/eslint.js
- /usr/src/app/bin/eslint.js
Referenced from: /code/.eslintrc
    at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15)
    at Function.resolve (node:internal/modules/cjs/helpers:108:19)
    at resolve (/usr/local/node_modules/eslint/lib/config/config-file.js:498:31)
    at load (/usr/local/node_modules/eslint/lib/config/config-file.js:579:26)
    at /usr/local/node_modules/eslint/lib/config/config-file.js:453:36
    at Array.reduceRight (<anonymous>)
    at applyExtends (/usr/local/node_modules/eslint/lib/config/config-file.js:431:26)
    at loadFromDisk (/usr/local/node_modules/eslint/lib/config/config-file.js:551:22)
    at Object.load (/usr/local/node_modules/eslint/lib/config/config-file.js:587:20)
    at Config.getLocalConfigHierarchy (/usr/local/node_modules/eslint/lib/config.js:240:44) {
  code: 'MODULE_NOT_FOUND',
  requireStack: [
    '/usr/local/node_modules/eslint/lib/config/config-file.js',
    '/usr/src/app/lib/eslint-patch.js',
    '/usr/src/app/lib/eslint.js',
    '/usr/src/app/bin/eslint.js'
  ]
}

Node.js v17.3.1