mysociety/alaveteli

View on GitHub
Gemfile.lock

Summary

Maintainability
Test Coverage
GIT
  remote: https://github.com/heapsource/active_model_otp.git
  revision: 55d93a3979907d8382c83c9b0f3e94e3186167fc
  ref: 55d93a3979
  specs:
    active_model_otp (1.2.0)
      activemodel
      rotp

GIT
  remote: https://github.com/mysociety/ruby-msg.git
  revision: fae72e547299ab1f8b23239a79f5a1d353426b40
  branch: ascii-encoding
  specs:
    ruby-msg (1.5.2)
      ruby-ole (>= 1.2.8)
      vpim (>= 0.360)

GIT
  remote: https://github.com/mysociety/strip_attributes.git
  revision: c1c14da7f33eda4cf5affaba01e6994155f7b7d4
  ref: c1c14da
  specs:
    strip_attributes (1.8.0)
      activemodel (>= 3.0, < 6.0)

GIT
  remote: https://github.com/technoweenie/acts_as_versioned.git
  revision: 63b1fc8529d028fae632fe80ec0cb25df56cd76b
  ref: 63b1fc8529d028
  specs:
    acts_as_versioned (0.6.0)
      activerecord (>= 3.0.9)

PATH
  remote: gems/alaveteli_features
  specs:
    alaveteli_features (0.0.1)
      flipper
      flipper-active_record
      mime-types (< 3.0.0)
      rails (>= 4.0.13, < 5.0)

GEM
  remote: https://rubygems.org/
  specs:
    actionmailer (4.2.10)
      actionpack (= 4.2.10)
      actionview (= 4.2.10)
      activejob (= 4.2.10)
      mail (~> 2.5, >= 2.5.4)
      rails-dom-testing (~> 1.0, >= 1.0.5)
    actionpack (4.2.10)
      actionview (= 4.2.10)
      activesupport (= 4.2.10)
      rack (~> 1.6)
      rack-test (~> 0.6.2)
      rails-dom-testing (~> 1.0, >= 1.0.5)
      rails-html-sanitizer (~> 1.0, >= 1.0.2)
    actionview (4.2.10)
      activesupport (= 4.2.10)
      builder (~> 3.1)
      erubis (~> 2.7.0)
      rails-dom-testing (~> 1.0, >= 1.0.5)
      rails-html-sanitizer (~> 1.0, >= 1.0.3)
    activejob (4.2.10)
      activesupport (= 4.2.10)
      globalid (>= 0.3.0)
    activemodel (4.2.10)
      activesupport (= 4.2.10)
      builder (~> 3.1)
    activerecord (4.2.10)
      activemodel (= 4.2.10)
      activesupport (= 4.2.10)
      arel (~> 6.0)
    activesupport (4.2.10)
      i18n (~> 0.7)
      minitest (~> 5.1)
      thread_safe (~> 0.3, >= 0.3.4)
      tzinfo (~> 1.1)
    addressable (2.4.0)
    annotate (2.7.2)
      activerecord (>= 3.2, < 6.0)
      rake (>= 10.4, < 13.0)
    arel (6.0.4)
    binding_of_caller (0.7.2)
      debug_inspector (>= 0.0.1)
    bootstrap-sass (2.3.2.2)
      sass (~> 3.2)
    builder (3.2.3)
    bullet (5.5.1)
      activesupport (>= 3.0.0)
      uniform_notifier (~> 1.10.0)
    byebug (9.0.6)
    cancancan (1.12.0)
    capistrano (2.15.9)
      highline
      net-scp (>= 1.0.0)
      net-sftp (>= 2.0.0)
      net-ssh (>= 2.0.14)
      net-ssh-gateway (>= 1.1.0)
    capybara (2.15.4)
      addressable
      mini_mime (>= 0.1.3)
      nokogiri (>= 1.3.3)
      rack (>= 1.0.0)
      rack-test (>= 0.5.4)
      xpath (~> 2.0)
    charlock_holmes (0.7.5)
    chronic (0.10.2)
    chunky_png (1.3.8)
    coderay (1.1.1)
    coffee-rails (4.2.2)
      coffee-script (>= 2.2.0)
      railties (>= 4.0.0)
    coffee-script (2.4.1)
      coffee-script-source
      execjs
    coffee-script-source (1.12.2)
    compass (1.0.3)
      chunky_png (~> 1.2)
      compass-core (~> 1.0.2)
      compass-import-once (~> 1.0.5)
      rb-fsevent (>= 0.9.3)
      rb-inotify (>= 0.9)
      sass (>= 3.3.13, < 3.5)
    compass-core (1.0.3)
      multi_json (~> 1.0)
      sass (>= 3.3.0, < 3.5)
    compass-import-once (1.0.5)
      sass (>= 3.2, < 3.5)
    compass-rails (3.0.2)
      compass (~> 1.0.0)
      sass-rails (< 5.1)
      sprockets (< 4.0)
    concurrent-ruby (1.0.5)
    coveralls (0.8.5)
      json (~> 1.8)
      rest-client (>= 1.6.8, < 2)
      simplecov (~> 0.10.0)
      term-ansicolor (~> 1.3)
      thor (~> 0.19.1)
    crass (1.0.2)
    daemons (1.2.4)
    dalli (2.7.6)
    dante (0.2.0)
    debug_inspector (0.0.3)
    delorean (2.1.0)
      chronic
    diff-lcs (1.3)
    docile (1.1.5)
    domain_name (0.5.20170223)
      unf (>= 0.0.5, < 1.0.0)
    dynamic_form (1.1.4)
    erubis (2.7.0)
    eventmachine (1.0.9.1)
    exception_notification (4.1.1)
      actionmailer (>= 3.0.4)
      activesupport (>= 3.0.4)
    execjs (2.7.0)
    factory_girl (4.8.0)
      activesupport (>= 3.0.0)
    factory_girl_rails (4.8.0)
      factory_girl (~> 4.8.0)
      railties (>= 3.0.0)
    fakeweb (1.3.0)
    fancybox-rails (0.3.1)
      railties (>= 3.1.0)
    faraday (0.13.1)
      multipart-post (>= 1.2, < 3)
    fast_gettext (1.1.0)
    ffi (1.9.18)
    flipper (0.10.2)
    flipper-active_record (0.10.2)
      activerecord (>= 3.2, < 6)
      flipper (~> 0.10.2)
    foundation-rails (5.5.3.2)
      railties (>= 3.1.0)
      sass (>= 3.3.0, < 3.5)
    gender_detector (1.0.0)
    geoip (1.6.3)
    gettext (2.3.9)
      locale
      text
    gettext_i18n_rails (0.9.4)
      fast_gettext (>= 0.4.8)
    globalid (0.4.0)
      activesupport (>= 4.2.0)
    globalize (5.0.1)
      activemodel (>= 4.2.0, < 4.3)
      activerecord (>= 4.2.0, < 4.3)
    gnuplot (2.6.2)
    highline (1.7.8)
    hodel_3000_compliant_logger (0.1.1)
    holidays (2.2.0)
    htmlentities (4.3.4)
    http-cookie (1.0.3)
      domain_name (~> 0.5)
    i18n (0.8.6)
    icalendar (2.4.1)
    iso_country_codes (0.7.6)
    jquery-rails (3.1.4)
      railties (>= 3.0, < 5.0)
      thor (>= 0.14, < 2.0)
    jquery-ui-rails (6.0.1)
      railties (>= 3.2.16)
    json (1.8.6)
    launchy (2.4.3)
      addressable (~> 2.3)
    libv8 (3.16.14.19)
    locale (2.0.9)
    loofah (2.1.1)
      crass (~> 1.0.2)
      nokogiri (>= 1.5.9)
    mahoro (0.4)
    mail (2.6.6)
      mime-types (>= 1.16, < 4)
    mailcatcher (0.6.5)
      eventmachine (= 1.0.9.1)
      mail (~> 2.3)
      rack (~> 1.5)
      sinatra (~> 1.2)
      skinny (~> 0.2.3)
      sqlite3 (~> 1.3)
      thin (~> 1.5.0)
    method_source (0.8.2)
    mime-types (2.99.3)
    mini_mime (0.1.4)
    mini_portile2 (2.1.0)
    minitest (5.10.3)
    money (6.10.0)
      i18n (>= 0.6.4, < 1.0)
    multi_json (1.12.1)
    multipart-post (2.0.0)
    net-http-local (0.1.2)
    net-scp (1.2.1)
      net-ssh (>= 2.6.5)
    net-sftp (2.1.2)
      net-ssh (>= 2.6.5)
    net-ssh (2.9.4)
    net-ssh-gateway (1.3.0)
      net-ssh (>= 2.6.5)
    netrc (0.11.0)
    newrelic_rpm (3.18.1.330)
    nokogiri (1.6.8.1)
      mini_portile2 (~> 2.1.0)
    oink (0.10.1)
      activerecord
      hodel_3000_compliant_logger
    open4 (1.3.4)
    pg (0.18.4)
    pry (0.10.4)
      coderay (~> 1.1.0)
      method_source (~> 0.8.1)
      slop (~> 3.4)
    pry-byebug (3.4.3)
      byebug (>= 9.0, < 9.1)
      pry (~> 0.10)
    public_suffix (1.4.6)
    quiet_assets (1.1.0)
      railties (>= 3.1, < 5.0)
    rack (1.6.8)
    rack-protection (1.5.3)
      rack
    rack-ssl (1.4.1)
      rack
    rack-test (0.6.3)
      rack (>= 1.0)
    rack-utf8_sanitizer (1.3.2)
      rack (>= 1.0, < 3.0)
    rails (4.2.10)
      actionmailer (= 4.2.10)
      actionpack (= 4.2.10)
      actionview (= 4.2.10)
      activejob (= 4.2.10)
      activemodel (= 4.2.10)
      activerecord (= 4.2.10)
      activesupport (= 4.2.10)
      bundler (>= 1.3.0, < 2.0)
      railties (= 4.2.10)
      sprockets-rails
    rails-deprecated_sanitizer (1.0.3)
      activesupport (>= 4.2.0.alpha)
    rails-dom-testing (1.0.8)
      activesupport (>= 4.2.0.beta, < 5.0)
      nokogiri (~> 1.6)
      rails-deprecated_sanitizer (>= 1.0.1)
    rails-html-sanitizer (1.0.3)
      loofah (~> 2.0)
    rails-i18n (4.0.9)
      i18n (~> 0.7)
      railties (~> 4.0)
    railties (4.2.10)
      actionpack (= 4.2.10)
      activesupport (= 4.2.10)
      rake (>= 0.8.7)
      thor (>= 0.18.1, < 2.0)
    rake (12.1.0)
    rb-fsevent (0.9.8)
    rb-inotify (0.9.8)
      ffi (>= 0.5.0)
    recaptcha (0.4.0)
    ref (2.0.0)
    rest-client (1.8.0)
      http-cookie (>= 1.0.2, < 2.0)
      mime-types (>= 1.16, < 3.0)
      netrc (~> 0.7)
    rmagick (2.16.0)
    rolify (5.1.0)
    rotp (3.3.0)
    routing-filter (0.5.1)
      actionpack (~> 4.2)
      activesupport (~> 4.2)
    rspec-activemodel-mocks (1.0.3)
      activemodel (>= 3.0)
      activesupport (>= 3.0)
      rspec-mocks (>= 2.99, < 4.0)
    rspec-core (3.5.4)
      rspec-support (~> 3.5.0)
    rspec-expectations (3.5.0)
      diff-lcs (>= 1.2.0, < 2.0)
      rspec-support (~> 3.5.0)
    rspec-mocks (3.5.0)
      diff-lcs (>= 1.2.0, < 2.0)
      rspec-support (~> 3.5.0)
    rspec-rails (3.5.2)
      actionpack (>= 3.0)
      activesupport (>= 3.0)
      railties (>= 3.0)
      rspec-core (~> 3.5.0)
      rspec-expectations (~> 3.5.0)
      rspec-mocks (~> 3.5.0)
      rspec-support (~> 3.5.0)
    rspec-support (3.5.0)
    ruby-ole (1.2.12)
    sass (3.4.21)
    sass-rails (5.0.6)
      railties (>= 4.0.0, < 6)
      sass (~> 3.1)
      sprockets (>= 2.8, < 4.0)
      sprockets-rails (>= 2.0, < 4.0)
      tilt (>= 1.1, < 3)
    secure_headers (3.6.5)
      useragent
    simplecov (0.10.0)
      docile (~> 1.1.0)
      json (~> 1.8)
      simplecov-html (~> 0.10.0)
    simplecov-html (0.10.0)
    sinatra (1.4.8)
      rack (~> 1.5)
      rack-protection (~> 1.4)
      tilt (>= 1.3, < 3)
    skinny (0.2.4)
      eventmachine (~> 1.0.0)
      thin (>= 1.5, < 1.7)
    slop (3.6.0)
    spring (2.0.2)
      activesupport (>= 4.2)
    spring-commands-rspec (1.0.4)
      spring (>= 0.9.1)
    sprockets (3.7.1)
      concurrent-ruby (~> 1.0)
      rack (> 1, < 3)
    sprockets-rails (3.2.1)
      actionpack (>= 4.0)
      activesupport (>= 4.0)
      sprockets (>= 3.0.0)
    sqlite3 (1.3.13)
    statistics2 (0.54)
    stripe (3.4.1)
      faraday (~> 0.10)
    stripe-ruby-mock (2.5.0)
      dante (>= 0.2.0)
      multi_json (~> 1.0)
      stripe (>= 2.0.3)
    syslog_protocol (0.9.2)
    term-ansicolor (1.3.2)
      tins (~> 1.0)
    test_after_commit (0.4.2)
      activerecord (>= 3.2)
    text (1.3.1)
    therubyracer (0.12.3)
      libv8 (~> 3.16.14.15)
      ref
    thin (1.5.1)
      daemons (>= 1.0.9)
      eventmachine (>= 0.12.6)
      rack (>= 1.0.0)
    thor (0.19.4)
    thread_safe (0.3.6)
    tilt (2.0.7)
    tins (1.3.0)
    tzinfo (1.2.3)
      thread_safe (~> 0.1)
    uglifier (3.2.0)
      execjs (>= 0.3.0, < 3)
    unf (0.1.4)
      unf_ext
    unf_ext (0.0.7.2)
    unicode (0.4.4.2)
    unidecoder (1.1.2)
    uniform_notifier (1.10.0)
    useragent (0.16.8)
    vpim (13.11.11)
    web-console (2.3.0)
      activemodel (>= 4.0)
      binding_of_caller (>= 0.7.2)
      railties (>= 4.0)
      sprockets-rails (>= 2.0, < 4.0)
    will_paginate (3.1.5)
    xapian-full-alaveteli (1.2.21.1)
    xml-simple (1.1.5)
    xpath (2.1.0)
      nokogiri (~> 1.3)
    zip (2.0.2)

PLATFORMS
  ruby

DEPENDENCIES
  active_model_otp!
  acts_as_versioned!
  alaveteli_features!
  annotate (~> 2.7.0)
  bootstrap-sass (~> 2.3.2.2)
  bullet (~> 5.5.0)
  cancancan (~> 1.12.0, < 1.13.0)
  capistrano (~> 2.15.0, < 3.0.0)
  capybara (~> 2.15.0)
  charlock_holmes (~> 0.7.0)
  coffee-rails (~> 4.2.0)
  compass-rails (~> 3.0.0)
  coveralls (~> 0.8.0)
  dalli (~> 2.7.0)
  delorean (~> 2.1.0)
  dynamic_form (~> 1.1.0)
  exception_notification (~> 4.1.0, < 4.1.2)
  factory_girl_rails (~> 4.8.0)
  fakeweb (~> 1.3.0)
  fancybox-rails (~> 0.3.0)
  fast_gettext (< 1.2.0)
  foundation-rails (~> 5.5.3.2)
  gender_detector (~> 1.0.0)
  geoip (~> 1.6.0)
  gettext (~> 2.3.0)
  gettext_i18n_rails (~> 0.9.0, < 1.0.0)
  globalize (~> 5.0.0, < 5.1.0)
  gnuplot (~> 2.6.0)
  holidays (~> 2.2.0, < 3.0.0)
  htmlentities (~> 4.3.0)
  icalendar (~> 2.4.0)
  iso_country_codes (~> 0.7.0)
  jquery-rails (~> 3.1.0, < 4.0.0)
  jquery-ui-rails (~> 6.0.0)
  json (~> 1.8.0, < 2.0.0)
  launchy (~> 2.4.0)
  locale (~> 2.0.0, < 2.1.0)
  mahoro (~> 0.4)
  mailcatcher (~> 0.6.0)
  mime-types (< 3.0.0)
  money (~> 6.10.0)
  net-http-local (~> 0.1.0)
  net-ssh (~> 2.9.0, < 3.0.0)
  newrelic_rpm
  nokogiri (~> 1.6.0, < 1.7)
  oink (~> 0.10.1)
  open4 (~> 1.3.0)
  pg (~> 0.18.0, < 0.19.0)
  pry (~> 0.10.0)
  pry-byebug (~> 3.4.0)
  public_suffix (~> 1.4.0, < 1.5.0)
  quiet_assets (~> 1.1.0)
  rack (~> 1.6.0)
  rack-ssl (~> 1.4.0)
  rack-utf8_sanitizer (~> 1.3.0)
  rails (= 4.2.10)
  rails-i18n (~> 4.0.0, < 5.0.0)
  recaptcha (~> 0.4.0, < 0.5.0)
  rmagick (~> 2.16.0)
  rolify (~> 5.1.0)
  routing-filter (~> 0.5.0, < 0.6.0)
  rspec-activemodel-mocks (~> 1.0.0)
  rspec-rails (~> 3.5.0)
  ruby-msg (~> 1.5.0)!
  sass (= 3.4.21)
  sass-rails (~> 5.0.0)
  secure_headers (~> 3.6.0)
  spring (~> 2.0.0)
  spring-commands-rspec (~> 1.0.0)
  statistics2 (~> 0.54)
  strip_attributes!
  stripe (~> 3.4.1)
  stripe-ruby-mock (~> 2.5.0)
  syslog_protocol (~> 0.9.0)
  term-ansicolor (~> 1.3.0, < 1.4)
  test_after_commit (~> 0.4.2)
  therubyracer (~> 0.12.0)
  thin (~> 1.5.0, < 1.6.0)
  tins (~> 1.3.0, < 1.3.1)
  uglifier (~> 3.2.0)
  unicode (~> 0.4.0)
  unidecoder (~> 1.1.0)
  vpim (~> 13.11.11)
  web-console (~> 2.3.0, < 3.0.0)
  will_paginate (~> 3.1.0)
  xapian-full-alaveteli (~> 1.2.21.1)
  xml-simple (~> 1.1.0)
  zip (~> 2.0.0)