neo4jrb/neo4j

View on GitHub
Merge branch 'driver_4.4' #79
Heinrich Klobuczek authored 0d1df67c
errored00:00:15
An engine encountered an error
E10 Error

We had trouble running the rubocop engine.

The engine's output shown below may indicate the cause of the error.

If not, please contact us so we can investigate further.

1
git clone
2
codeclimate validate-config
View output
codeclimate validate-config
No errors or warnings found in .codeclimate.yml.
3
codeclimate prepare
View output
codeclimate prepare
4
builder pull-engines
View output
determining required images
5
structure
View output
12
Parser process id: 12
codeclimate-parser socket not present
waiting 1s...
6
duplication
View output
13
Parser process id: 13
codeclimate-parser socket not present
waiting 1s...
I, [2022-07-31T00:36:31.858460 #1]  INFO -- : Skipping file ./lib/active_graph/transactions.rb due to exception (Racc::ParseError): ./lib/active_graph/transactions.rb:12 :: parse error on value "**" (error)
7
rubocop
rubocop engine documentation
View output
Warning: unrecognized cop Naming/MemoizedInstanceVariableName found in .rubocop_todo.yml
Warning: unrecognized cop Naming/UncommunicativeMethodParamName found in .rubocop_todo.yml
Warning: unrecognized cop Style/MethodMissingSuper found in .rubocop_todo.yml
Warning: unrecognized cop Style/MissingRespondToMissing found in .rubocop_todo.yml
Warning: unrecognized cop Naming/MemoizedInstanceVariableName found in .rubocop.yml
Warning: unrecognized cop Naming/UncommunicativeMethodParamName found in .rubocop.yml
Warning: unrecognized cop Style/MethodMissingSuper found in .rubocop.yml
Warning: unrecognized cop Style/MissingRespondToMissing found in .rubocop.yml
/usr/local/bundle/gems/rubocop-0.52.1/lib/rubocop/config.rb:510:in `check_target_ruby': Unknown Ruby version 2.6 found in `TargetRubyVersion` parameter (in .rubocop.yml). (RuboCop::ValidationError)
Supported versions: 2.1, 2.2, 2.3, 2.4, 2.5
	from /usr/local/bundle/gems/rubocop-0.52.1/lib/rubocop/config.rb:313:in `validate'
	from /usr/local/bundle/gems/rubocop-0.52.1/lib/rubocop/config.rb:201:in `check'
	from /usr/local/bundle/gems/rubocop-0.52.1/lib/rubocop/config.rb:194:in `create'
	from /usr/local/bundle/gems/rubocop-0.52.1/lib/rubocop/config_loader.rb:48:in `load_file'
	from /usr/local/bundle/gems/rubocop-0.52.1/lib/rubocop/config_loader.rb:79:in `configuration_from_file'
	from /usr/local/bundle/gems/rubocop-0.52.1/lib/rubocop/config_store.rb:44:in `for'
	from /usr/src/app/lib/cc/engine/file_list_resolver.rb:38:in `rubocop_file_to_include?'
	from /usr/src/app/lib/cc/engine/file_list_resolver.rb:16:in `block in expanded_list'
	from /usr/src/app/lib/cc/engine/file_list_resolver.rb:13:in `each'
	from /usr/src/app/lib/cc/engine/file_list_resolver.rb:13:in `flat_map'
	from /usr/src/app/lib/cc/engine/file_list_resolver.rb:13:in `expanded_list'
	from /usr/src/app/lib/cc/engine/rubocop.rb:49:in `files_to_inspect'
	from /usr/src/app/lib/cc/engine/rubocop.rb:29:in `block in run'
	from /usr/src/app/lib/cc/engine/rubocop.rb:28:in `chdir'
	from /usr/src/app/lib/cc/engine/rubocop.rb:28:in `run'
	from /usr/src/app/bin/codeclimate-rubocop:17:in `<main>'