publiclab/plots2

View on GitHub
Commit details not available #7091
ed26d04d
complete00:01:07
1
git clone
2
codeclimate validate-config
View output
codeclimate validate-config
WARNING: 'engines' has been deprecated, please use 'plugins' instead
WARNING: 'exclude_paths' has been deprecated, please use 'exclude_patterns' instead
WARNING: 'ratings' has been deprecated, and will not be used
3
codeclimate prepare
View output
codeclimate prepare
4
builder pull-engines
View output
determining required images
5
structure
View output
12
Parser process id: 12
codeclimate-parser socket not present
waiting 1s...
W, [2019-05-20T13:48:42.673309 #1]  WARN -- : Skipping public/emoji.js due to CC::Parser::Client::HTTPError
W, [2019-05-20T13:48:42.673411 #1]  WARN -- : Response status: 422
W, [2019-05-20T13:48:42.677421 #1]  WARN -- : Skipping public/bookmarklet.js due to CC::Parser::Client::HTTPError
W, [2019-05-20T13:48:42.677494 #1]  WARN -- : Response status: 422
W, [2019-05-20T13:48:43.107677 #1]  WARN -- : Skipping app/assets/javascripts/ics.min.js due to CC::Parser::Client::HTTPError
W, [2019-05-20T13:48:43.107912 #1]  WARN -- : Response status: 422
W, [2019-05-20T13:48:43.140722 #1]  WARN -- : Skipping app/assets/javascripts/ics.deps.min.js due to CC::Parser::Client::HTTPError
W, [2019-05-20T13:48:43.141026 #1]  WARN -- : Response status: 422
6
duplication
View output
14
Parser process id: 14
codeclimate-parser socket not present
waiting 1s...
/usr/local/ruby-2.5.1/lib/ruby/gems/2.5.0/gems/concurrent-ruby-1.0.0/lib/concurrent/atomic/mutex_atomic_fixnum.rb:80: warning: constant ::Fixnum is deprecated
/usr/local/ruby-2.5.1/lib/ruby/gems/2.5.0/gems/concurrent-ruby-1.0.0/lib/concurrent/atomic/mutex_atomic_fixnum.rb:80: warning: constant ::Fixnum is deprecated
W, [2019-05-20T13:48:54.558782 #1]  WARN -- : Skipping ./public/emoji.js due to CC::Parser::Client::HTTPError
W, [2019-05-20T13:48:54.558887 #1]  WARN -- : Response status: 422
W, [2019-05-20T13:48:54.588597 #1]  WARN -- : Skipping ./public/bookmarklet.js due to CC::Parser::Client::HTTPError
W, [2019-05-20T13:48:54.588943 #1]  WARN -- : Response status: 422
W, [2019-05-20T13:48:55.208046 #1]  WARN -- : Skipping ./app/assets/javascripts/ics.min.js due to CC::Parser::Client::HTTPError
W, [2019-05-20T13:48:55.208636 #1]  WARN -- : Response status: 422
W, [2019-05-20T13:48:55.214279 #1]  WARN -- : Skipping ./app/assets/javascripts/ics.deps.min.js due to CC::Parser::Client::HTTPError
W, [2019-05-20T13:48:55.214987 #1]  WARN -- : Response status: 422
7
brakeman
brakeman engine documentation
8
bundler-audit
bundler-audit engine documentation
9
eslint
eslint engine documentation
View output
ESLint is running with the default parser.
.eslintrc appears to be incompatible with ESLint 3.
We've attempted to fix any compatibility issues.
Note: some of these warnings may originate in configurations you are extending.
If analysis succeeds, you have nothing to worry about.
To upgrade it do the following:

* Add .yml or .json to the config file name. Extension-less config file names are deprecated.
* Set sourceType to "module" in parserOptions section
* Remove modules from ecmaFeatures section
* Set ecmaVersion to 6 in parserOptions section
* Move ecmaFeatures section under parserOptions section
* Remove no-arrow-condition rule and add the following:

    "no-confusing-arrow": "off",
    "no-constant-condition": [
        "off",
        {
            "checkLoops": false
        }
    ]


* Remove no-empty-label rule and add the following:

    "no-labels": [
        "error",
        {
            "allowLoop": true
        }
    ]


* Remove space-after-keywords rule and add the following:

    "keyword-spacing": [
        "off",
        {
            "after": false
        }
    ]


* Remove space-before-keywords rule and add the following:

    "keyword-spacing": [
        "off",
        {
            "before": false
        }
    ]


* Remove space-return-throw-case rule and add the following:

    "keyword-spacing": [
        "off",
        {
            "after": true
        }
    ]



WARN: Skipping public/bookmarklet.js: it appears to be minified
WARN: Skipping public/emoji.js: it appears to be minified
WARN: Skipping app/assets/javascripts/application/i18n/translations.js: it appears to be minified
WARN: Skipping app/assets/javascripts/ics.deps.min.js: it appears to be minified
WARN: Skipping app/assets/javascripts/ics.min.js: it appears to be minified
10
fixme
fixme engine documentation
11
rubocop
rubocop engine documentation
View output
.rubocop.yml: Layout/EndAlignment has the wrong namespace - should be Lint
.rubocop.yml: Layout/DefEndAlignment has the wrong namespace - should be Lint
.rubocop_shopify_styleguide.yml: Layout/BlockAlignment has the wrong namespace - should be Lint
.rubocop_shopify_styleguide.yml: Layout/DefEndAlignment has the wrong namespace - should be Lint
.rubocop_shopify_styleguide.yml: Lint/FlipFlop has the wrong namespace - should be Style
.rubocop_shopify_styleguide.yml: Layout/ConditionPosition has the wrong namespace - should be Lint
Warning: unrecognized cop Naming/UncommunicativeMethodParamName found in .rubocop_todo.yml
Warning: unrecognized cop Security/Open found in .rubocop_todo.yml
Warning: unrecognized cop Naming/UncommunicativeMethodParamName found in .rubocop.yml
Warning: unrecognized cop Security/Open found in .rubocop.yml