unixorn/awesome-zsh-plugins

View on GitHub
zsh-plugin-assessor/zsh-plugin-assessor

Summary

Maintainability
Test Coverage

'(' is invalid here. Did you forget to escape it?
Open

[[ -z "$1" || "$1" = (-h|--help) ]] && {

Expected another argument for this operator.
Open

[[ -z "$1" || "$1" = (-h|--help) ]] && {

Fix any mentioned problems and try again.
Open

[[ -z "$1" || "$1" = (-h|--help) ]] && {

Unexpected ..

Note: There is a [known bug](../issues/1036) in the current version when [directives](../wiki/Directive) appear within then clauses of if blocks that causes Shellcheck to report SC1072 on otherwise valid code. Avoid using directives within then clauses - instead place them at the top of the if block or another enclosing block. This is fixed on the online version and the next release.

See Parser Error.

Notice

Original content from the ShellCheck https://github.com/koalaman/shellcheck/wiki.

Couldn't parse this test expression.
Open

[[ -z "$1" || "$1" = (-h|--help) ]] && {

Couldn't parse this ...

This parsing error points to the structure ShellCheck was trying to parse when a parser error occurred. See [[Parser error]] for more information.

Notice

Original content from the ShellCheck https://github.com/koalaman/shellcheck/wiki.

There are no issues that match your filters.

Category
Status