3scale/porta

View on GitHub
app/lib/payment_gateways/payment_gateway_crypt.rb

Summary

Maintainability
A
0 mins
Test Coverage

PaymentGateways::PaymentGatewayCrypt#log_gateway_action_explicit calls 'Rails.logger.info "----------"' 2 times
Open

      Rails.logger.info "----------"
      Rails.logger.info "~>[Payment gateway][#{gateway&.display_name}] #{action}"
      Rails.logger.info "----------"

Duplication occurs when two fragments of code look nearly identical, or when two fragments of code have nearly identical effects at some conceptual level.

Reek implements a check for Duplicate Method Call.

Example

Here's a very much simplified and contrived example. The following method will report a warning:

def double_thing()
  @other.thing + @other.thing
end

One quick approach to silence Reek would be to refactor the code thus:

def double_thing()
  thing = @other.thing
  thing + thing
end

A slightly different approach would be to replace all calls of double_thing by calls to @other.double_thing:

class Other
  def double_thing()
    thing + thing
  end
end

The approach you take will depend on balancing other factors in your code.

PaymentGateways::PaymentGatewayCrypt#log_gateway_action_explicit calls 'Rails.logger' 3 times
Open

      Rails.logger.info "----------"
      Rails.logger.info "~>[Payment gateway][#{gateway&.display_name}] #{action}"
      Rails.logger.info "----------"

Duplication occurs when two fragments of code look nearly identical, or when two fragments of code have nearly identical effects at some conceptual level.

Reek implements a check for Duplicate Method Call.

Example

Here's a very much simplified and contrived example. The following method will report a warning:

def double_thing()
  @other.thing + @other.thing
end

One quick approach to silence Reek would be to refactor the code thus:

def double_thing()
  thing = @other.thing
  thing + thing
end

A slightly different approach would be to replace all calls of double_thing by calls to @other.double_thing:

class Other
  def double_thing()
    thing + thing
  end
end

The approach you take will depend on balancing other factors in your code.

PaymentGateways::PaymentGatewayCrypt#test? doesn't depend on instance state (maybe move it to another class?)
Open

    def test?

A Utility Function is any instance method that has no dependency on the state of the instance.

PaymentGateways::PaymentGatewayCrypt#notify_exception has the parameter name 'e'
Open

    def notify_exception(e, query_string = nil)

An Uncommunicative Parameter Name is a parameter name that doesn't communicate its intent well enough.

Poor names make it hard for the reader to build a mental picture of what's going on in the code. They can also be mis-interpreted; and they hurt the flow of reading, because the reader must slow down to interpret the names.

There are no issues that match your filters.

Category
Status