3scale/porta

View on GitHub
db/migrate/20080716131833_remove_backend_ids.rb

Summary

Maintainability
A
0 mins
Test Coverage

RemoveBackendIds#self.down has the variable name 't'
Open

    change_table :cinstances do |t|
      t.integer :backend_id
    end

    change_table :contracts do |t|

An Uncommunicative Variable Name is a variable name that doesn't communicate its intent well enough.

Poor names make it hard for the reader to build a mental picture of what's going on in the code. They can also be mis-interpreted; and they hurt the flow of reading, because the reader must slow down to interpret the names.

RemoveBackendIds#self.up has the variable name 't'
Open

    change_table :services do |t|
      t.remove :backend_service_id
    end

    change_table :contracts do |t|

An Uncommunicative Variable Name is a variable name that doesn't communicate its intent well enough.

Poor names make it hard for the reader to build a mental picture of what's going on in the code. They can also be mis-interpreted; and they hurt the flow of reading, because the reader must slow down to interpret the names.

There are no issues that match your filters.

Category
Status