3scale/porta

View on GitHub
db/migrate/20081119135532_remove_viewstatus_from_profiles_and_accounts.rb

Summary

Maintainability
A
0 mins
Test Coverage

RemoveViewstatusFromProfilesAndAccounts#self.up calls 't.remove :viewstatus' 2 times
Open

      t.remove :viewstatus
    end

    change_table :accounts do |t|
      t.remove :viewstatus

Duplication occurs when two fragments of code look nearly identical, or when two fragments of code have nearly identical effects at some conceptual level.

Reek implements a check for Duplicate Method Call.

Example

Here's a very much simplified and contrived example. The following method will report a warning:

def double_thing()
  @other.thing + @other.thing
end

One quick approach to silence Reek would be to refactor the code thus:

def double_thing()
  thing = @other.thing
  thing + thing
end

A slightly different approach would be to replace all calls of double_thing by calls to @other.double_thing:

class Other
  def double_thing()
    thing + thing
  end
end

The approach you take will depend on balancing other factors in your code.

RemoveViewstatusFromProfilesAndAccounts#self.down calls 't.string :viewstatus, :default => 'PRIVATE'' 2 times
Open

      t.string :viewstatus, :default => 'PRIVATE'
    end

    change_table :accounts do |t|
      t.string :viewstatus, :default => 'PRIVATE'

Duplication occurs when two fragments of code look nearly identical, or when two fragments of code have nearly identical effects at some conceptual level.

Reek implements a check for Duplicate Method Call.

Example

Here's a very much simplified and contrived example. The following method will report a warning:

def double_thing()
  @other.thing + @other.thing
end

One quick approach to silence Reek would be to refactor the code thus:

def double_thing()
  thing = @other.thing
  thing + thing
end

A slightly different approach would be to replace all calls of double_thing by calls to @other.double_thing:

class Other
  def double_thing()
    thing + thing
  end
end

The approach you take will depend on balancing other factors in your code.

RemoveViewstatusFromProfilesAndAccounts#self.down has the variable name 't'
Open

    change_table :profiles do |t|
      t.string :viewstatus, :default => 'PRIVATE'
    end

    change_table :accounts do |t|

An Uncommunicative Variable Name is a variable name that doesn't communicate its intent well enough.

Poor names make it hard for the reader to build a mental picture of what's going on in the code. They can also be mis-interpreted; and they hurt the flow of reading, because the reader must slow down to interpret the names.

RemoveViewstatusFromProfilesAndAccounts#self.up has the variable name 't'
Open

    change_table :profiles do |t|
      t.remove :viewstatus
    end

    change_table :accounts do |t|

An Uncommunicative Variable Name is a variable name that doesn't communicate its intent well enough.

Poor names make it hard for the reader to build a mental picture of what's going on in the code. They can also be mis-interpreted; and they hurt the flow of reading, because the reader must slow down to interpret the names.

There are no issues that match your filters.

Category
Status