IBM-Swift/Kitura

View on GitHub
Sources/Kitura/Kitura.swift

Summary

Maintainability
A
0 mins
Test Coverage

Function names should be lowerCamelCase
Open

    private class func _addHTTPServer(on listenType: ListenerType,
Severity: Minor
Found in Sources/Kitura/Kitura.swift by tailor

lower-camel-case

method and var names should follow lowerCamelCase naming convention: first letter of the entire word is lowercase, but subsequent first letters are uppercase.

Method and selector names

Preferred

func someMethod() {
    // method definition goes here
}

Not Preferred

func some-method() {
    // method definition goes here
}

Variable names

Preferred

var someVariable = someValue

Not Preferred

var Some_Var1able = someValue

There are no issues that match your filters.

Category
Status