countries/country_select

View on GitHub
country_select.gemspec

Summary

Maintainability
Test Coverage
# -*- encoding: utf-8 -*-
$:.push File.expand_path('../lib', __FILE__)
require 'country_select/version'

Gem::Specification.new do |s|
  s.name        = 'country_select'
  s.version     = CountrySelect::VERSION
  s.licenses    = ['MIT']
  s.authors     = ['Stefan Penner']
  s.email       = ['stefan.penner@gmail.com']
  s.homepage    = 'https://github.com/countries/country_select'
  s.summary     = %q{Country Select Plugin}
  s.description = %q{Provides a simple helper to get an HTML select list of countries. The list of countries comes from the ISO 3166 standard. While it is a relatively neutral source of country names, it will still offend some users.}

  s.metadata      = { 'bug_tracker_uri' => 'http://github.com/countries/country_select/issues',
                      'changelog_uri' =>  'https://github.com/countries/country_select/blob/master/CHANGELOG.md',
                      'source_code_uri' =>  'https://github.com/countries/country_select' }

  s.files         = `git ls-files`.split("\n")
  s.test_files    = `git ls-files -- {test,spec,features}/*`.split("\n")
  s.executables   = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
  s.require_paths = ['lib']

  s.required_ruby_version = '>= 2.7'

  s.add_development_dependency 'actionpack', '~> 7.0'
  s.add_development_dependency 'pry', '~> 0'
  s.add_development_dependency 'rake', '~> 13'
  s.add_development_dependency 'rspec', '~> 3'

  s.add_dependency 'countries', '~> 5.0'
end