creof/wkb-parser

View on GitHub
lib/CrEOF/Geo/WKB/Reader.php

Summary

Maintainability
A
0 mins
Test Coverage

The 'getMachineByteOrder()' method which returns a boolean should be named 'is...()' or 'has...()'
Open

    private function getMachineByteOrder()
    {
        if (null === self::$machineByteOrder) {
            $result = unpack('S', "\x01\x00");

Severity: Minor
Found in lib/CrEOF/Geo/WKB/Reader.php by phpmd

BooleanGetMethodName

Since: 0.2

Looks for methods named 'getX()' with 'boolean' as the return type. The convention is to name these methods 'isX()' or 'hasX()'.

Example

class Foo {
    /**
     * @return boolean
     */
    public function getFoo() {} // bad
    /**
     * @return bool
     */
    public function isFoo(); // ok
    /**
     * @return boolean
     */
    public function getFoo($bar); // ok, unless checkParameterizedMethods=true
}

Source https://phpmd.org/rules/naming.html#booleangetmethodname

There are no issues that match your filters.

Category
Status