decko-commons/decko

View on GitHub
card/lib/card/auth/permissions.rb

Summary

Maintainability
A
0 mins
Test Coverage
A
97%

Rename has_role? to role?.
Open

      def has_role? role_mark, user_mark=nil
Severity: Minor
Found in card/lib/card/auth/permissions.rb by rubocop

This cop makes sure that predicates are named properly.

Example:

# bad
def is_even?(value)
end

# good
def even?(value)
end

# bad
def has_value?
end

# good
def value?
end

There are no issues that match your filters.

Category
Status